2015 Savana Stabilitrak problem - GMC Savana Forum
User Tag List

 
Thread Tools
post #1 of 2 (permalink) Old 08-01-2018, 10:06 PM Thread Starter
Junior Member
 
Join Date: Mar 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question 2015 Savana Stabilitrak problem

I have a 2015 Savana 2500 long wheel based Explorer conversion van with the 6.0L engine. Less than 32,000 miles but outside of the three-year warranty.


The past year the engine acts as if it's missing when accelerating (idling is generally smooth). Lately the "service Stabilitrak" message has been randomly popping up. I had the same problem with my wife's 2009 Cadillac DTS and come to find out one of the ignition packs had failed (why Stabilitrak is tied to ignition coils confuses me). Is it safe to assume I'm facing the same problem with the van? It certainly would make sense.
rmurtland is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-19-2020, 06:21 PM
Junior Member
 
Join Date: May 2020
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sensor

I just replaced the sensor mounted on the steering column. 2016 Express. Took my time and had it done under 3 hrs. Part is around 100$. My service stabilitrak light is now off. Hope it stays that way. Some u-tube videos out there --most deal with pickups but it will give you the basic instructions. Now I need to get the service air bag light to go away.
diamondx is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
3rd brake light problem Jack Rivers Electronics 1 12-20-2017 05:39 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome